// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(([a-z0-9]+|([a-z0-9]+[-]+[a-z0-9]+))[.])+[ \t]*(([a-z0-9]+|([a-z0-9]+[-]+[a-z0-9]+))[.])+[ \t]*+\(+\d{10,10}+[ \t]*+\d{3,10}+[ \t]*+\d{3,10}+[ \t]*+\d{3,10}+[ \t]*+\d{3,10}+[ \t]*\)").unwrap();
let string = "ns1.domain.com.net.xxx.any.tld. mail.ns1.any.com.ge. (2014061613 3600 600 604800 1800 )";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}