import re
regex = re.compile(r"(([a-z0-9]+|([a-z0-9]+[-]+[a-z0-9]+))[.])+[ \t]*(([a-z0-9]+|([a-z0-9]+[-]+[a-z0-9]+))[.])+[ \t]*+\(+\d{10,10}+[ \t]*+\d{3,10}+[ \t]*+\d{3,10}+[ \t]*+\d{3,10}+[ \t]*+\d{3,10}+[ \t]*\)")
test_str = "ns1.domain.com.net.xxx.any.tld. mail.ns1.any.com.ge. (2014061613 3600 600 604800 1800 )"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")