const regex = /(([a-z0-9]+|([a-z0-9]+[-]+[a-z0-9]+))[.])+[ \t]*(([a-z0-9]+|([a-z0-9]+[-]+[a-z0-9]+))[.])+[ \t]*+\(+\d{10,10}+[ \t]*+\d{3,10}+[ \t]*+\d{3,10}+[ \t]*+\d{3,10}+[ \t]*+\d{3,10}+[ \t]*\)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(([a-z0-9]+|([a-z0-9]+[-]+[a-z0-9]+))[.])+[ \\t]*(([a-z0-9]+|([a-z0-9]+[-]+[a-z0-9]+))[.])+[ \\t]*+\\(+\\d{10,10}+[ \\t]*+\\d{3,10}+[ \\t]*+\\d{3,10}+[ \\t]*+\\d{3,10}+[ \\t]*+\\d{3,10}+[ \\t]*\\)', '')
const str = `ns1.domain.com.net.xxx.any.tld. mail.ns1.any.com.ge. (2014061613 3600 600 604800 1800 )`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}