import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(([a-z0-9]+|([a-z0-9]+[-]+[a-z0-9]+))[.])+[ \\t]*(([a-z0-9]+|([a-z0-9]+[-]+[a-z0-9]+))[.])+[ \\t]*+\\(+\\d{10,10}+[ \\t]*+\\d{3,10}+[ \\t]*+\\d{3,10}+[ \\t]*+\\d{3,10}+[ \\t]*+\\d{3,10}+[ \\t]*\\)";
final String string = "ns1.domain.com.net.xxx.any.tld. mail.ns1.any.com.ge. (2014061613 3600 600 604800 1800 )";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}