#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b(25[0-5]|2[0-4][0-9]|[01]?[0-9]{1,2}\.){3}(25[0-5]|2[0-4][0-9]|[01]?[0-9]{1,2})\b"
Local $sString = "1.2.3.4" & @CRLF & _
"1.2.3.100" & @CRLF & _
"1.2.3.199" & @CRLF & _
"1.2.3.255" & @CRLF & _
"1.2.3.256" & @CRLF & _
"1.2.3.300"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")