re = /\b(25[0-5]|2[0-4][0-9]|[01]?[0-9]{1,2}\.){3}(25[0-5]|2[0-4][0-9]|[01]?[0-9]{1,2})\b/
str = '1.2.3.4
1.2.3.100
1.2.3.199
1.2.3.255
1.2.3.256
1.2.3.300'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end