// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\b(25[0-5]|2[0-4][0-9]|[01]?[0-9]{1,2}\.){3}(25[0-5]|2[0-4][0-9]|[01]?[0-9]{1,2})\b").unwrap();
let string = "1.2.3.4
1.2.3.100
1.2.3.199
1.2.3.255
1.2.3.256
1.2.3.300";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}