import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(25[0-5]|2[0-4][0-9]|[01]?[0-9]{1,2}\\.){3}(25[0-5]|2[0-4][0-9]|[01]?[0-9]{1,2})\\b";
final String string = "1.2.3.4\n"
+ "1.2.3.100\n"
+ "1.2.3.199\n"
+ "1.2.3.255\n"
+ "1.2.3.256\n"
+ "1.2.3.300";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}