use strict;
my $str = '1.2.3.4
1.2.3.100
1.2.3.199
1.2.3.255
1.2.3.256
1.2.3.300';
my $regex = qr/\b(25[0-5]|2[0-4][0-9]|[01]?[0-9]{1,2}\.){3}(25[0-5]|2[0-4][0-9]|[01]?[0-9]{1,2})\b/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}