using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*?)\badd\(\$\w+(?:\h*,\h*\$\w+)+\)";
string input = @"add($arg1, $agr2)
test add($arg1, $agr2)
test 2 add($arg1, $agr2, $arg3)
test 2 add($arg1, $agr2, $arg3, $arg4)
test 2 add($arg1)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}