$re = '/(.*?)\badd\(\$\w+(?:\h*,\h*\$\w+)+\)/m';
$str = 'add($arg1, $agr2)
test add($arg1, $agr2)
test 2 add($arg1, $agr2, $arg3)
test 2 add($arg1, $agr2, $arg3, $arg4)
test 2 add($arg1)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);