import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*?)\\badd\\(\\$\\w+(?:\\h*,\\h*\\$\\w+)+\\)";
final String string = "add($arg1, $agr2)\n"
+ "test add($arg1, $agr2)\n"
+ "test 2 add($arg1, $agr2, $arg3)\n"
+ "test 2 add($arg1, $agr2, $arg3, $arg4)\n"
+ "test 2 add($arg1)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}