re = /(.*?)\badd\(\$\w+(?:\h*,\h*\$\w+)+\)/m
str = 'add($arg1, $agr2)
test add($arg1, $agr2)
test 2 add($arg1, $agr2, $arg3)
test 2 add($arg1, $agr2, $arg3, $arg4)
test 2 add($arg1)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end