import re
regex = re.compile(r"(.*?)\badd\(\$\w+(?:\h*,\h*\$\w+)+\)", flags=re.MULTILINE)
test_str = ("add($arg1, $agr2)\n"
"test add($arg1, $agr2)\n"
"test 2 add($arg1, $agr2, $arg3)\n"
"test 2 add($arg1, $agr2, $arg3, $arg4)\n"
"test 2 add($arg1)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")