#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=\/running\/)(?<processtype>pre-process|process)\/(?<tracker>[1|2])"
Local $sString = "/running/pre-process/1" & @CRLF & _
"/running/process/1/lorem" & @CRLF & _
"/running/pre-process/2" & @CRLF & _
"/running/process/2/lorem" & @CRLF & _
"/running/pre-process/2" & @CRLF & _
"/running/process/2/lorem?ipsum=123" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")