using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\/running\/)(?<processtype>pre-process|process)\/(?<tracker>[1|2])";
string input = @"/running/pre-process/1
/running/process/1/lorem
/running/pre-process/2
/running/process/2/lorem
/running/pre-process/2
/running/process/2/lorem?ipsum=123
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}