import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\/running\\/)(?<processtype>pre-process|process)\\/(?<tracker>[1|2])";
final String string = "/running/pre-process/1\n"
+ "/running/process/1/lorem\n"
+ "/running/pre-process/2\n"
+ "/running/process/2/lorem\n"
+ "/running/pre-process/2\n"
+ "/running/process/2/lorem?ipsum=123\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}