const regex = /(?<=\/running\/)(?<processtype>pre-process|process)\/(?<tracker>[1|2])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\\/running\\\/)(?<processtype>pre-process|process)\\\/(?<tracker>[1|2])', 'gm')
const str = `/running/pre-process/1
/running/process/1/lorem
/running/pre-process/2
/running/process/2/lorem
/running/pre-process/2
/running/process/2/lorem?ipsum=123
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}