using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(\w+)[^>]+>[^>]+test string";
string input = @"<section class=""test-class1""><div><hussain class=""test-class2"">something else..<mkh>..test string</p></div></section>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}