$re = '/<(\w+)[^>]+>[^>]+test string/';
$str = '<section class="test-class1"><div><hussain class="test-class2">something else..<mkh>..test string</p></div></section>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);