const regex = /<(\w+)[^>]+>[^>]+test string/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<(\\w+)[^>]+>[^>]+test string', 'g')
const str = `<section class="test-class1"><div><hussain class="test-class2">something else..<mkh>..test string</p></div></section>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}