re = /<(\w+)[^>]+>[^>]+test string/
str = '<section class="test-class1"><div><hussain class="test-class2">something else..<mkh>..test string</p></div></section>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end