// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<(\w+)[^>]+>[^>]+test string").unwrap();
let string = "<section class=\"test-class1\"><div><hussain class=\"test-class2\">something else..<mkh>..test string</p></div></section>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}