# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[(?:\[|\[[^\]]*\|)([^\]\|]+)\]\]/\1/gm;t' <<< "This is a note linked to [[Note-2 |another note]] and maybe [[Note1]] "