using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[(?:\[|\[[^\]]*\|)([^\]\|]+)\]\]";
string substitution = @"\1";
string input = @"This is a note linked to [[Note-2 |another note]] and maybe [[Note1]] ";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}