$re = '/\[(?:\[|\[[^\]]*\|)([^\]\|]+)\]\]/m';
$str = 'This is a note linked to [[Note-2 |another note]] and maybe [[Note1]] ';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;