package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[(?:\[|\[[^\]]*\|)([^\]\|]+)\]\]`)
var str = `This is a note linked to [[Note-2 |another note]] and maybe [[Note1]] `
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}