#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.*word1\s+(?:\S+\s+){0,3}word2.*$).*"
Local $sString = "text text word1 text text word2 text text" & @CRLF & _
"text text word1 text text text word2 text text" & @CRLF & _
"text text word1 text text text text word2 text text" & @CRLF & _
"text text word1 word2 text text" & @CRLF & _
"text text word1 text text word2 text text" & @CRLF & _
"text text word1 text text word5 text text" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")