$re = '/^(?=.*word1\s+(?:\S+\s+){0,3}word2.*$).*/m';
$str = 'text text word1 text text word2 text text
text text word1 text text text word2 text text
text text word1 text text text text word2 text text
text text word1 word2 text text
text text word1 text text word2 text text
text text word1 text text word5 text text
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);