use strict;
my $str = 'text text word1 text text word2 text text
text text word1 text text text word2 text text
text text word1 text text text text word2 text text
text text word1 word2 text text
text text word1 text text word2 text text
text text word1 text text word5 text text
';
my $regex = qr/^(?=.*word1\s+(?:\S+\s+){0,3}word2.*$).*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}