import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*word1\\s+(?:\\S+\\s+){0,3}word2.*$).*";
final String string = "text text word1 text text word2 text text\n"
+ "text text word1 text text text word2 text text\n"
+ "text text word1 text text text text word2 text text\n"
+ "text text word1 word2 text text\n"
+ "text text word1 text text word2 text text\n"
+ "text text word1 text text word5 text text\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}