using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*word1\s+(?:\S+\s+){0,3}word2.*$).*";
string input = @"text text word1 text text word2 text text
text text word1 text text text word2 text text
text text word1 text text text text word2 text text
text text word1 word2 text text
text text word1 text text word2 text text
text text word1 text text word5 text text
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}