import re
regex = re.compile((r"(^.*\/home\/virtfs.*$)|(^.*\/net\/dba.*$)\n"), flags=re.MULTILINE)
test_str = ("/home/virtfs/lingfieldmeth/etc/alternatives\n"
"/home/software/cfs\n"
"/home/virtfs/lingfieldmeth/etc/mail\n"
"/run/user/1005\n"
"/etc\n"
"/var/log\n"
"/usr/local\n"
"/net/dba/cats\n"
"/net/dbb/dogs\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")