package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*?XY_Universit.`)
var str = `XY_Universit�-WWWWW-ZZZZZ askdja XY_Universit�-WWWWW-ZZZZZ`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}