re = /.*?XY_Universit./
str = 'XY_Universit�-WWWWW-ZZZZZ askdja XY_Universit�-WWWWW-ZZZZZ'
# Print the match result
str.match(re) do |match|
puts match.to_s
end