const regex = /.*?XY_Universit./;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*?XY_Universit.', '')
const str = `XY_Universit�-WWWWW-ZZZZZ askdja XY_Universit�-WWWWW-ZZZZZ`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}