# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((["'])(?:\\.|.)*?\2)|\/\/.*?$|\/\*[\s\S]*?\*\//$1/gm;t' <<< "
\"// Code\",
'// Code',
\"'// Code\",
'\"// Code',
//\" Comment\",
//' Comment',
/* Comment */
// Comment /* Comment
/* Comment
Comment // */ \"Code\",
\"Code\",
\"/* Code */\",
\"/* Code\",
\"Code */\",
'/* Code */',
'/* Code',
'Code */',
/* Comment
\"Comment\",
Comment */ \"Code\"
"