$re = '@((["\'])(?:\\\\.|.)*?\2)|//.*?$|/\*[\s\S]*?\*/@m';
$str = '
"// Code",
\'// Code\',
"\'// Code",
\'"// Code\',
//" Comment",
//\' Comment\',
/* Comment */
// Comment /* Comment
/* Comment
Comment // */ "Code",
"Code",
"/* Code */",
"/* Code",
"Code */",
\'/* Code */\',
\'/* Code\',
\'Code */\',
/* Comment
"Comment",
Comment */ "Code"
';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;