using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(([""'])(?:\\.|.)*?\2)|//.*?$|/\*[\s\S]*?\*/";
string substitution = @"$1";
string input = @"
""// Code"",
'// Code',
""'// Code"",
'""// Code',
//"" Comment"",
//' Comment',
/* Comment */
// Comment /* Comment
/* Comment
Comment // */ ""Code"",
""Code"",
""/* Code */"",
""/* Code"",
""Code */"",
'/* Code */',
'/* Code',
'Code */',
/* Comment
""Comment"",
Comment */ ""Code""
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}