use strict;
my $str = '
"// Code",
\'// Code\',
"\'// Code",
\'"// Code\',
//" Comment",
//\' Comment\',
/* Comment */
// Comment /* Comment
/* Comment
Comment // */ "Code",
"Code",
"/* Code */",
"/* Code",
"Code */",
\'/* Code */\',
\'/* Code\',
\'Code */\',
/* Comment
"Comment",
Comment */ "Code"
';
my $regex = qr@((["'])(?:\\.|.)*?\2)|//.*?$|/\*[\s\S]*?\*/@mp;
my $subst = '$1';
my $result = $str =~ s@$regex@$subst@rg;
print "The result of the substitution is' $result\n";