#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)((["'])(?:\\.|.)*?\2)|//.*?$|/\*[\s\S]*?\*/"
Local $sString = "" & @CRLF & _
" "// Code"," & @CRLF & _
" '// Code'," & @CRLF & _
" "'// Code"," & @CRLF & _
" '"// Code'," & @CRLF & _
" //" Comment"," & @CRLF & _
" //' Comment'," & @CRLF & _
" /* Comment */" & @CRLF & _
" // Comment /* Comment" & @CRLF & _
" /* Comment" & @CRLF & _
" Comment // */ "Code"," & @CRLF & _
" "Code"," & @CRLF & _
" "/* Code */"," & @CRLF & _
" "/* Code"," & @CRLF & _
" "Code */"," & @CRLF & _
" '/* Code */'," & @CRLF & _
" '/* Code'," & @CRLF & _
" 'Code */'," & @CRLF & _
" /* Comment" & @CRLF & _
" "Comment"," & @CRLF & _
" Comment */ "Code"" & @CRLF & _
""
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)