#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^/csr_and_sustainability_information/([^i\n]|i(i|f(i|r(i|a(i|mi))))*([^fi]|f([^ir]|r([^ai]|a([^im]|m[^ei])))))*(i(i|f(i|r(i|a(i|mi))))*(f(r?|ram?))?)?$"
Local $sString = "/csr_and_sustainability_information/blahblah/blah/blah-iframe-asd" & @CRLF & _
"" & @CRLF & _
"/csr_and_sustainability_information/blahblah/blah/blah-" & @CRLF & _
"" & @CRLF & _
"/csr_and_sustainability_information/blahblah/blah/blah-" & @CRLF & _
"" & @CRLF & _
"/csr_and_sustainability_information/blahblah-iframe-blah/blah/blah-asdhaud/iframe"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")