import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^/csr_and_sustainability_information/([^i\\n]|i(i|f(i|r(i|a(i|mi))))*([^fi]|f([^ir]|r([^ai]|a([^im]|m[^ei])))))*(i(i|f(i|r(i|a(i|mi))))*(f(r?|ram?))?)?$";
final String string = "/csr_and_sustainability_information/blahblah/blah/blah-iframe-asd\n\n"
+ "/csr_and_sustainability_information/blahblah/blah/blah-\n\n"
+ "/csr_and_sustainability_information/blahblah/blah/blah-\n\n"
+ "/csr_and_sustainability_information/blahblah-iframe-blah/blah/blah-asdhaud/iframe";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}