use strict;
my $str = '/csr_and_sustainability_information/blahblah/blah/blah-iframe-asd
/csr_and_sustainability_information/blahblah/blah/blah-
/csr_and_sustainability_information/blahblah/blah/blah-
/csr_and_sustainability_information/blahblah-iframe-blah/blah/blah-asdhaud/iframe';
my $regex = qr~^/csr_and_sustainability_information/([^i\n]|i(i|f(i|r(i|a(i|mi))))*([^fi]|f([^ir]|r([^ai]|a([^im]|m[^ei])))))*(i(i|f(i|r(i|a(i|mi))))*(f(r?|ram?))?)?$~mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}