using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^/csr_and_sustainability_information/([^i\n]|i(i|f(i|r(i|a(i|mi))))*([^fi]|f([^ir]|r([^ai]|a([^im]|m[^ei])))))*(i(i|f(i|r(i|a(i|mi))))*(f(r?|ram?))?)?$";
string input = @"/csr_and_sustainability_information/blahblah/blah/blah-iframe-asd
/csr_and_sustainability_information/blahblah/blah/blah-
/csr_and_sustainability_information/blahblah/blah/blah-
/csr_and_sustainability_information/blahblah-iframe-blah/blah/blah-asdhaud/iframe";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}