import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
    public static void main(String[] args) {
        final String regex = "(close_app|open_app)";
        final String string = "https://app.twinpush.com/api/v2/apps/f1ad9f0348ea3149/devices/147680904a9a9f66/open_app\n\n";
        final String subst = "";
        
        final Pattern pattern = Pattern.compile(regex);
        final Matcher matcher = pattern.matcher(string);
        
        // The substituted value will be contained in the result variable
        final String result = matcher.replaceFirst(subst);
        
        System.out.println("Substitution result: " + result);
    }
}