use strict;
my $str = 'https://app.twinpush.com/api/v2/apps/f1ad9f0348ea3149/devices/147680904a9a9f66/open_app
';
my $regex = qr/(close_app|open_app)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";