using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:[^\n][\n]?)+) #flashcard ?\n*\(tab\)((?:(?:.{1,3}$|.{4}(?<!<!--).*)\n?)+)";
string input = @"- Art. 970. A lei assegurará tratamento Favorecido, Diferenciado e Simplificado ao #flashcard
(tab)- Empresário rural e ao
(tab)- Pequeno empresário
group 1:- Art. 970. A lei assegurará tratamento Favorecido, Diferenciado e Simplificado ao
group 2:
(tab)- Empresário rural e ao
(tab)- Pequeno empresário";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}