$re = '/((?:[^\n][\n]?)+) #flashcard ?\n*\(tab\)((?:(?:.{1,3}$|.{4}(?<!<!--).*)\n?)+)/m';
$str = '- Art. 970. A lei assegurará tratamento Favorecido, Diferenciado e Simplificado ao #flashcard
(tab)- Empresário rural e ao
(tab)- Pequeno empresário
group 1:- Art. 970. A lei assegurará tratamento Favorecido, Diferenciado e Simplificado ao
group 2:
(tab)- Empresário rural e ao
(tab)- Pequeno empresário';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);