use strict;
my $str = '- Art. 970. A lei assegurará tratamento Favorecido, Diferenciado e Simplificado ao #flashcard
(tab)- Empresário rural e ao
(tab)- Pequeno empresário
group 1:- Art. 970. A lei assegurará tratamento Favorecido, Diferenciado e Simplificado ao
group 2:
(tab)- Empresário rural e ao
(tab)- Pequeno empresário';
my $regex = qr/((?:[^\n][\n]?)+) #flashcard ?\n*\(tab\)((?:(?:.{1,3}$|.{4}(?<!<!--).*)\n?)+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}